Supported Devices

Devices for Mapping

For best possible quality, we recommend using one of the following devices:

  • Nexus 5 & 5X
  • Nexus 6P
  • Honor 8
  • LG G4 & G5
  • OnePlus 2 & 3
  • Oppo R9s

Other Android devices including the needed sensors; accelerometer, magnetometer, gyroscope) and OS-version 5 or newer can be used as well. Please note the device needs to have hardware sensors - e.g. a virtual gyroscope does not provide the needed data.

Samsung devices are not recommended for mapping because of the sensor filtering that prevents IndoorAtlas positioning from working in an optimal way.

Devices for Positioning

To run IndoorAtlas SDK on an Android device, API level 10 (Gingerbread) is required. For the most accurate positioning experience, gyroscope and magnetometer are needed. On the iOS side, IndoorAtlas SDKs work on iPhone 4S and newer models.